Overview
You are experiencing an intermittent problem where some of your installed process templates or applications are not found in the application dropdown lists on the Management Pages of the BPM Portal. When you encounter this issue, a restart of the Aurea Process server will allow the BPM Portal to display all of the installed applications in the application dropdown lists.
Prerequisite
- Any of the following versions of Aurea Process:
- 2015 SP1 with Hotfix 10 or higher applied.
- 2016 R2 release or newer
Solution
Diagnosis
The issue was identified and an option was added as of Aurea Process 2015 SP1 Hotfix 10 and Aurea Process 2016 R2 that allows for process template or application name caching to be disabled.
Solution Steps
To disable the process template or application name caching, you will need to do the following:
- Open the SBM_HOME/conf/resources/common/distcache/appcacheconfig.xml file.
- In the file, find PC_PTID_PTNAME_CACHE node and set enabled to false as shown below:
<CacheCategory name="PROCESSCACHE" enable="true"> <Cache name="PC_PROCESSMETADATACACHE"/> <Cache name="PC_PTID_PTNAME_CACHE" enable="false" /> </CacheCategory>
- Restart the servers to have the changes take effect.