Overview
When a non-admin user tries to click on a user profile hyperlink in the top right corner in the Aurea Process (CX Process, Savvion or SBM) BPM Portal, they get the following error:
java.lang.NullPointerException
at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1270)
at java.util.ResourceBundle.getBundle(ResourceBundle.java:852)
at sun.util.resources.LocaleData$1.run(LocaleData.java:154)
at sun.util.resources.LocaleData$1.run(LocaleData.java:152)
Prerequisites
You will need one of the following depending on the solution being applied:
- Permission to upgrade the Aurea Process server
- Permission to update the profile.jsp file on the Aurea Process server
- Administrator access to the Aurea Process BPM Portal
Solution
Diagnosis
This happens when Aurea Process is configured with LDAP or Hybrid realm and more than one language is configured. When a user is created in LDAP, the default locale is not assigned causing calls to the userProfile.getLocale() method to return a null value instead of a locale which results in the NullPointerException.
Solution Steps
This issue was identified and fixed with the release of Aurea Process 2020 SP1. If you are using an earlier release of Aurea Process 2020 SP1, you will need to upgrade to Aurea Process 2020 SP1 or a more recent release.
Workaround
If you are unable to upgrade your Aurea Process server to Aurea Process 2020 SP1 or a more recent release, you can apply one of the following workarounds to your Aurea Process BPM Portal:
- Modify the profile.jsp to ensure that if the userProfile.getLocale() call returns null, that we apply a default locale for the user. The profile.jsp file can be found at $IBM\WebSphere\AppServer\profiles\<profile_name>\installedApps\<cell_name>\sbm_war.ear\sbm.war\bpmportal\myhome\profile.jsp.
- Open the profile.jsp file in a text editor.
- Replace each instance of userProfile.getLocale() with (null==userProfile.getLocale())? new Locale("en"):userProfile.getLocale().
- Save the changes to the profile.jsp file.
- Ensure a locale is applied to the user's account by doing the following:
- From an administrator account, go to Administration > User Management.
- Locate the user that is having the issue and open the user's details.
- Save the user (even if there are no changes).
- The user's profile should now be accessible.
Testing
Once the Aurea Process server is upgraded to Aurea Process 2020 SP1 or one of the workarounds is applied, the user's profile should now be accessing